What’s Vulnerable › Vulnerabilities
CVE-2022-24749: Basic Cross-site Scripting and Unrestricted Upload of File with Dangerous Type in Sylius
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-80
Description
Sylius is an open source eCommerce platform. In versions prior to 1.9.10, 1.10.11, and 1.11.2, it is possible to upload an SVG file containing cross-site scripting (XSS) code in the admin panel. In order to perform a XSS attack, the file itself has to be open in a new card or loaded outside of the IMG tag. The problem applies both to the files opened on the admin panel and shop pages. The issue is fixed in versions 1.9.10, 1.10.11, and 1.11.2. As a workaround, require a library that adds on-upload file sanitization and overwrite the service before writing the file to the filesystem. The GitHub Security Advisory contains more specific information about the workaround.
Affected products
- Sylius: before 1.9.10; from 1.10.0 before 1.10.11; from 1.11.0 before 1.11.2 — fixed in 1.10.11, 1.11.2, 1.9.10
How to fix
Upgrade to a fixed version: Sylius 1.10.11, 1.11.2, 1.9.10. Check the vendor advisory for mitigations.
References
- https://github.com/Sylius/Sylius/releases/tag/v1.10.11
- https://github.com/Sylius/Sylius/releases/tag/v1.11.2
- https://github.com/Sylius/Sylius/releases/tag/v1.9.10
- https://github.com/Sylius/Sylius/security/advisories/GHSA-4qrp-27r3-66fj
- https://github.com/Sylius/Sylius/releases/tag/v1.10.11
- https://github.com/Sylius/Sylius/releases/tag/v1.11.2
- https://github.com/Sylius/Sylius/releases/tag/v1.9.10
- https://github.com/Sylius/Sylius/security/advisories/GHSA-4qrp-27r3-66fj
Get alerted when CVE-2022-24749 or the next vulnerability affects your stack