What’s Vulnerable › Vulnerabilities

CVE-2022-24755: Incorrect Authorization in Bareos Director

Description

Bareos is open source software for backup, archiving, and recovery of data for operating systems. When Bareos Director >= 18.2 >= 18.2 but prior to 21.1.0, 20.0.6, and 19.2.12 is built and configured for PAM authentication, it will skip authorization checks completely. Expired accounts and accounts with expired passwords can still login. This problem will affect users that have PAM enabled. Currently there is no authorization (e.g. check for expired or disabled accounts), but only plain authentication (i.e. check if username and password match). Bareos Director versions 21.1.0, 20.0.6 and 19.2.12 implement the authorization check that was previously missing. The only workaround is to make sure that authentication fails if the user is not authorized.

Affected products

How to fix

Upgrade to a fixed version: bareos 19.2.12, 20.0.6, 21.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24755 or the next vulnerability affects your stack