What’s Vulnerable › Vulnerabilities
CVE-2022-24759: Failure to validate signature during handshake in @chainsafe/libp2p-noise
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-17 · updated 2026-06-17
- Weakness: CWE-347
Description
`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.
Affected products
- ChainSafe js-libp2p-noise: before 4.1.2; from 5.0.0 before 5.0.3 — fixed in 4.1.2, 5.0.3
How to fix
Upgrade to a fixed version: ChainSafe js-libp2p-noise 4.1.2, 5.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/ChainSafe/js-libp2p-noise/pull/130
- https://github.com/ChainSafe/js-libp2p-noise/releases/tag/v5.0.3
- https://github.com/ChainSafe/js-libp2p-noise/security/advisories/GHSA-j3ff-xp6c-6gcc
- https://github.com/ChainSafe/js-libp2p-noise/pull/130
- https://github.com/ChainSafe/js-libp2p-noise/releases/tag/v5.0.3
- https://github.com/ChainSafe/js-libp2p-noise/security/advisories/GHSA-j3ff-xp6c-6gcc
Get alerted when CVE-2022-24759 or the next vulnerability affects your stack