What’s Vulnerable › Vulnerabilities
CVE-2022-24762: Exposure of Sensitive Information to an Unauthorized Actor in sysend.js
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-200
Description
sysend.js is a library that allows a user to send messages between pages that are open in the same browser. Users that use cross-origin communication may have their communications intercepted. Impact is limited by the communication occurring in the same browser. This issue has been patched in sysend.js version 1.10.0. The only currently known workaround is to avoid sending communications that a user does not want to have intercepted via sysend messages.
Affected products
- jcubic sysend.js: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: jcubic sysend.js 1.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/jcubic/sysend.js/commit/a24f4b776fb18191ae0f7e3d90c2c7bec459431a
- https://github.com/jcubic/sysend.js/issues/33
- https://github.com/jcubic/sysend.js/releases/tag/1.10.0
- https://github.com/jcubic/sysend.js/security/advisories/GHSA-4vvg-x86p-mvqc
- https://github.com/jcubic/sysend.js/commit/a24f4b776fb18191ae0f7e3d90c2c7bec459431a
- https://github.com/jcubic/sysend.js/issues/33
- https://github.com/jcubic/sysend.js/releases/tag/1.10.0
- https://github.com/jcubic/sysend.js/security/advisories/GHSA-4vvg-x86p-mvqc
Get alerted when CVE-2022-24762 or the next vulnerability affects your stack