What’s Vulnerable › Vulnerabilities
CVE-2022-24763: Infinite Loop in PJSIP
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-30 · updated 2026-06-17
- Weakness: CWE-835
Description
PJSIP is a free and open source multimedia communication library written in the C language. Versions 2.12 and prior contain a denial-of-service vulnerability that affects PJSIP users that consume PJSIP's XML parsing in their apps. Users are advised to update. There are no known workarounds.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- teluu pjsip: from 2.5 before 2.13 — fixed in 2.13
How to fix
Upgrade to a fixed version: teluu pjsip 2.13. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/856f87c2e97a27b256482dbe0d748b1194355a21
- https://github.com/pjsip/pjproject/security/advisories/GHSA-5x45-qp78-g4p4
- https://lists.debian.org/debian-lts-announce/2022/05/msg00047.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00021.html
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html
- https://security.gentoo.org/glsa/202210-37
- https://www.debian.org/security/2022/dsa-5285
- https://github.com/pjsip/pjproject/commit/856f87c2e97a27b256482dbe0d748b1194355a21
- https://github.com/pjsip/pjproject/security/advisories/GHSA-5x45-qp78-g4p4
- https://lists.debian.org/debian-lts-announce/2022/05/msg00047.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00021.html
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html
Get alerted when CVE-2022-24763 or the next vulnerability affects your stack