What’s Vulnerable › Vulnerabilities

CVE-2022-24775: Improper Input Validation in guzzlehttp/psr7

Description

guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

Affected products

How to fix

Upgrade to a fixed version: Drupal 9.2.16, 9.3.9; Guzzlephp Psr-7 1.8.4, 2.1.1; Packagist Guzzlehttp/Psr7 1.8.4, 2.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24775 or the next vulnerability affects your stack