What’s Vulnerable › Vulnerabilities
CVE-2022-24777: Denial of Service via reachable assertion in grpc-swift
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-25 · updated 2026-06-17
- Weakness: CWE-617
Description
grpc-swift is the Swift language implementation of gRPC, a remote procedure call (RPC) framework. Prior to version 1.7.2, a grpc-swift server is vulnerable to a denial of service attack via a reachable assertion. This is due to incorrect logic when handling GOAWAY frames. The attack is low-effort: it takes very little resources to construct and send the required sequence of frames. The impact on availability is high as the server will crash, dropping all in flight connections and requests. This issue is fixed in version 1.7.2. There are currently no known workarounds.
Affected products
- grpc-swift: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: grpc-swift 1.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/grpc/grpc-swift/commit/858f977f2a51fca2292f384cf7a108dc2e73a3bd
- https://github.com/grpc/grpc-swift/security/advisories/GHSA-r6ww-5963-7r95
- https://github.com/grpc/grpc-swift/commit/858f977f2a51fca2292f384cf7a108dc2e73a3bd
- https://github.com/grpc/grpc-swift/security/advisories/GHSA-r6ww-5963-7r95
Get alerted when CVE-2022-24777 or the next vulnerability affects your stack