What’s Vulnerable › Vulnerabilities
CVE-2022-24788: Buffer overflow in Vyper
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-13 · updated 2026-06-17
- Weakness: CWE-120
Description
Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. Versions of vyper prior to 0.3.2 suffer from a potential buffer overrun. Importing a function from a JSON interface which returns `bytes` generates bytecode which does not clamp bytes length, potentially resulting in a buffer overrun. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- vyperlang vyper: before 0.3.2 — fixed in 0.3.2
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b
- https://github.com/vyperlang/vyper/security/advisories/GHSA-4mrx-6fxm-8jpg
- https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b
- https://github.com/vyperlang/vyper/security/advisories/GHSA-4mrx-6fxm-8jpg
Get alerted when CVE-2022-24788 or the next vulnerability affects your stack