What’s Vulnerable › Vulnerabilities
CVE-2022-24790: HTTP Request Smuggling in puma
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-30 · updated 2026-06-17
- Weakness: CWE-444
Description
Puma is a simple, fast, multi-threaded, parallel HTTP 1.1 server for Ruby/Rack applications. When using Puma behind a proxy that does not properly validate that the incoming HTTP request matches the RFC7230 standard, Puma and the frontend proxy may disagree on where a request starts and ends. This would allow requests to be smuggled via the front-end proxy to Puma. The vulnerability has been fixed in 5.6.4 and 4.3.12. Users are advised to upgrade as soon as possible. Workaround: when deploying a proxy in front of Puma, turning on any and all functionality to make sure that the request matches the RFC7230 standard.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36, 37
- puma: before 4.3.12; from 5.0.0 before 5.6.4 — fixed in 4.3.12, 5.6.4
- Rubygems Puma: from 5.0.0 before 5.6.4; before 4.3.12; 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.1.0 (+140) — fixed in 5.6.4, 4.3.12
How to fix
Upgrade to a fixed version: puma 4.3.12, 5.6.4; Rubygems Puma 5.6.4, 4.3.12. Check the vendor advisory for mitigations.
References
- https://github.com/puma/puma/commit/5bb7d202e24dec00a898dca4aa11db391d7787a5
- https://github.com/puma/puma/security/advisories/GHSA-h99w-9q5r-gjq9
- https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/F6YWGIIKL7KKTS3ZOAYMYPC7D6WQ5OA5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L7NESIBFCNSR3XH7LXDPKVMSUBNUB43G/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TUBFJ44NCKJ34LECZRAP4N5VL6USJSIB/
- https://security.gentoo.org/glsa/202208-28
- https://www.debian.org/security/2022/dsa-5146
- https://github.com/puma/puma/commit/5bb7d202e24dec00a898dca4aa11db391d7787a5
- https://github.com/puma/puma/security/advisories/GHSA-h99w-9q5r-gjq9
- https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/F6YWGIIKL7KKTS3ZOAYMYPC7D6WQ5OA5/
Get alerted when CVE-2022-24790 or the next vulnerability affects your stack