What’s Vulnerable › Vulnerabilities
CVE-2022-24794: Open Redirect in express-openid-connect
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-31 · updated 2026-06-17
- Weakness: CWE-601
Description
Express OpenID Connect is an Express JS middleware implementing sign on for Express web apps using OpenID Connect. Users of the `requiresAuth` middleware, either directly or through the default `authRequired` option, are vulnerable to an Open Redirect when the middleware is applied to a catch all route. If all routes under `example.com` are protected with the `requiresAuth` middleware, a visit to `http://example.com//google.com` will be redirected to `google.com` after login because the original url reported by the Express framework is not properly sanitized. This vulnerability affects versions prior to 2.7.2. Users are advised to upgrade. There are no known workarounds.
Affected products
- auth0 express-openid-connect: before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: auth0 express-openid-connect 2.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/auth0/express-openid-connect/commit/0947b92164a2c5f661ebcc183d37e7f21de719ad
- https://github.com/auth0/express-openid-connect/security/advisories/GHSA-7p99-3798-f85c
- https://github.com/auth0/express-openid-connect/commit/0947b92164a2c5f661ebcc183d37e7f21de719ad
- https://github.com/auth0/express-openid-connect/security/advisories/GHSA-7p99-3798-f85c
Get alerted when CVE-2022-24794 or the next vulnerability affects your stack