What’s Vulnerable › Vulnerabilities
CVE-2022-24797: Exposure of Sensitive Information in Pomerium
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-31 · updated 2026-06-17
- Weakness: CWE-200
Description
Pomerium is an identity-aware access proxy. In distributed service mode, Pomerium's Authenticate service exposes pprof debug and prometheus metrics handlers to untrusted traffic. This can leak potentially sensitive environmental information or lead to limited denial of service conditions. This issue is patched in version v0.17.1 Workarounds: Block access to `/debug` and `/metrics` paths on the authenticate service. This can be done with any L7 proxy, including Pomerium's own proxy service.
Affected products
- pomerium: from 0.16.0 before 0.17.1 — fixed in 0.17.1
How to fix
Upgrade to a fixed version: pomerium 0.17.1. Check the vendor advisory for mitigations.
References
- https://github.com/pomerium/pomerium/commit/b435f73e2b54088da2aca5e8c3aa1808293d6903
- https://github.com/pomerium/pomerium/pull/3212
- https://github.com/pomerium/pomerium/security/advisories/GHSA-q98f-2x4p-prjr
- https://github.com/pomerium/pomerium/commit/b435f73e2b54088da2aca5e8c3aa1808293d6903
- https://github.com/pomerium/pomerium/pull/3212
- https://github.com/pomerium/pomerium/security/advisories/GHSA-q98f-2x4p-prjr
Get alerted when CVE-2022-24797 or the next vulnerability affects your stack