What’s Vulnerable › Vulnerabilities
CVE-2022-24807: net-snmp: A malformed OID in a SET request to SNMP-VIEW-BASED-ACM-MIB::vacmAccessTable can cause an out-of-bounds memory access
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-120
Description
net-snmp provides various tools relating to the Simple Network Management Protocol. Prior to version 5.9.2, a malformed OID in a SET request to `SNMP-VIEW-BASED-ACM-MIB::vacmAccessTable` can cause an out-of-bounds memory access. A user with read-write credentials can exploit the issue. Version 5.9.2 contains a patch. Users should use strong SNMPv3 credentials and avoid sharing the credentials. Those who must use SNMPv1 or SNMPv2c should use a complex community string and enhance the protection by restricting access to a given IP address range.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 36
- net-snmp: before 5.9.2 — fixed in 5.9.2
- Red Hat Enterprise Linux: 9.0
- RedHat Enterprise Linux Eus: 9.2, 9.4
- RedHat Enterprise Linux For Arm 64: 9.0, 9.2_aarch64, 9.4_aarch64
- RedHat Enterprise Linux For Arm 64 Eus: 9.4_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 9.0, 9.2_s390x, 9.4_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 9.4_s390x
- RedHat Enterprise Linux For Power Little Endian: 9.0
- RedHat Enterprise Linux For Power Little Endian Eus: 9.2_ppc64le, 9.4_ppc64le
- RedHat Enterprise Linux Server Aus: 9.2, 9.4
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 9.2_ppc64le
- RedHat Enterprise Linux Server Update Services For Sap Solutions: 9.2
- RedHat Enterprise Linux Update Services For Sap Solutions: 9.4
How to fix
Upgrade to a fixed version: net-snmp 5.9.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2103225
- https://bugzilla.redhat.com/show_bug.cgi?id=2105239
- https://github.com/net-snmp/net-snmp/commit/67ebb43e9038b2dae6e74ae8838b36fcc10fc937
- https://github.com/net-snmp/net-snmp/commit/ce66eb97c17aa9a48bc079be7b65895266fa6775
- https://lists.debian.org/debian-lts-announce/2022/08/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FX75KKGMO5XMV6JMQZF6KOG3JPFNQBY7/
- https://security.gentoo.org/glsa/202210-29
- https://www.debian.org/security/2022/dsa-5209
- https://bugzilla.redhat.com/show_bug.cgi?id=2103225
- https://bugzilla.redhat.com/show_bug.cgi?id=2105239
- https://github.com/net-snmp/net-snmp/commit/67ebb43e9038b2dae6e74ae8838b36fcc10fc937
- https://github.com/net-snmp/net-snmp/commit/ce66eb97c17aa9a48bc079be7b65895266fa6775
Get alerted when CVE-2022-24807 or the next vulnerability affects your stack