What’s Vulnerable › Vulnerabilities
CVE-2022-24811: Cross-site Scripting in Combodo iTop
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Combodi iTop is a web based IT Service Management tool. Prior to versions 2.7.6 and 3.0.0, cross-site scripting is possible for scripts outside of script tags when displaying HTML attachments. This issue is fixed in versions 2.7.6 and 3.0.0. There are currently no known workarounds.
Affected products
- Combodo iTop: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: Combodo iTop 2.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/Combodo/iTop/commit/92a9a8c65f3cbb2cd4414ca3a3b45a5754ba57b4
- https://github.com/Combodo/iTop/security/advisories/GHSA-67x5-mqg4-rvgc
- https://huntr.dev/bounties/1625056478879-Combodo/iTop/
- https://github.com/Combodo/iTop/commit/92a9a8c65f3cbb2cd4414ca3a3b45a5754ba57b4
- https://github.com/Combodo/iTop/security/advisories/GHSA-67x5-mqg4-rvgc
- https://huntr.dev/bounties/1625056478879-Combodo/iTop/
Get alerted when CVE-2022-24811 or the next vulnerability affects your stack