What’s Vulnerable › Vulnerabilities
CVE-2022-24814: Cross-site Scripting in Directus
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Directus is a real-time API and App dashboard for managing SQL database content. Prior to version 9.7.0, unauthorized JavaScript (JS) can be executed by inserting an iframe into the rich text html interface that links to a file uploaded HTML file that loads another uploaded JS file in its script tag. This satisfies the regular content security policy header, which in turn allows the file to run any arbitrary JS. This issue was resolved in version 9.7.0. As a workaround, disable the live embed in the what-you-see-is-what-you-get by adding `{ "media_live_embeds": false }` to the _Options Overrides_ option of the Rich Text HTML interface.
Affected products
- Rangerstudio Directus: before 9.7.0 — fixed in 9.7.0
How to fix
Upgrade to a fixed version: Rangerstudio Directus 9.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/directus/directus/pull/12020
- https://github.com/directus/directus/releases/tag/v9.7.0
- https://github.com/directus/directus/security/advisories/GHSA-xmjj-3c76-5w84
- https://github.com/directus/directus/pull/12020
- https://github.com/directus/directus/releases/tag/v9.7.0
- https://github.com/directus/directus/security/advisories/GHSA-xmjj-3c76-5w84
Get alerted when CVE-2022-24814 or the next vulnerability affects your stack