What’s Vulnerable › Vulnerabilities
CVE-2022-24818: Unchecked JNDI lookups in GeoTools
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-13 · updated 2026-06-17
- Weakness: CWE-20
Description
GeoTools is an open source Java library that provides tools for geospatial data. The GeoTools library has a number of data sources that can perform unchecked JNDI lookups, which in turn can be used to perform class deserialization and result in arbitrary code execution. Similar to the Log4J case, the vulnerability can be triggered if the JNDI names are user-provided, but requires admin-level login to be triggered. The lookups are now restricted in GeoTools 26.4, GeoTools 25.6, and GeoTools 24.6. Users unable to upgrade should ensure that any downstream application should not allow usage of remotely provided JNDI strings.
Affected products
- geotools: before 24.6; from 25.0 before 25.6; from 26.0 before 26.4 — fixed in 24.6, 25.6, 26.4
How to fix
Upgrade to a fixed version: geotools 24.6, 25.6, 26.4. Check the vendor advisory for mitigations.
References
- https://github.com/geotools/geotools/commit/4f70fa3234391dd0cda883a20ab0ec75688cba49
- https://github.com/geotools/geotools/security/advisories/GHSA-jvh2-668r-g75x
- https://github.com/geotools/geotools/commit/4f70fa3234391dd0cda883a20ab0ec75688cba49
- https://github.com/geotools/geotools/security/advisories/GHSA-jvh2-668r-g75x
Get alerted when CVE-2022-24818 or the next vulnerability affects your stack