What’s Vulnerable › Vulnerabilities
CVE-2022-24821: Incorrect Use of Privileged APIs in org.xwiki.platform.skin.skinx
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-08 · updated 2026-06-17
- Weakness: CWE-648
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Simple users can create global SSX/JSX without specific rights: in theory only users with Programming Rights should be allowed to create SSX or JSX that are executed everywhere on a wiki. But a bug allow anyone with edit rights to actually create those. This issue has been patched in XWiki 13.10-rc-1, 12.10.11 and 13.4.6. There's no easy workaround for this issue, administrators should upgrade their wiki.
Affected products
- xwiki-platform: from 12.0.0 before 12.10.11; from 13.4.0 before 13.4.6; 13.10 — fixed in 12.10.11, 13.4.6
How to fix
Upgrade to a fixed version: xwiki-platform 12.10.11, 13.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-ghcq-472w-vf4h
- https://jira.xwiki.org/browse/XWIKI-19155
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-ghcq-472w-vf4h
- https://jira.xwiki.org/browse/XWIKI-19155
Get alerted when CVE-2022-24821 or the next vulnerability affects your stack