What’s Vulnerable › Vulnerabilities
CVE-2022-24822: Denial of Service in @podium/layout and @podium/proxy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-06 · updated 2026-06-17
- Weakness: CWE-248
Description
Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.
Affected products
- Finn Podium Layout: before 4.6.110 — fixed in 4.6.110
- Finn Podium Proxy: before 4.2.74 — fixed in 4.2.74
How to fix
Upgrade to a fixed version: Finn Podium Layout 4.6.110; Finn Podium Proxy 4.2.74. Check the vendor advisory for mitigations.
References
- https://github.com/podium-lib/layout/commit/fe43e655432b0a5f07b6475f67babcc2588fb039
- https://github.com/podium-lib/layout/releases/tag/v4.6.110
- https://github.com/podium-lib/proxy/commit/9698a40df081217ce142d4de71f929baaa339cdf
- https://github.com/podium-lib/proxy/releases/tag/v4.2.74
- https://github.com/podium-lib/proxy/security/advisories/GHSA-3hjg-vc7r-rcrw
- https://github.com/podium-lib/layout/commit/fe43e655432b0a5f07b6475f67babcc2588fb039
- https://github.com/podium-lib/layout/releases/tag/v4.6.110
- https://github.com/podium-lib/proxy/commit/9698a40df081217ce142d4de71f929baaa339cdf
- https://github.com/podium-lib/proxy/releases/tag/v4.2.74
- https://github.com/podium-lib/proxy/security/advisories/GHSA-3hjg-vc7r-rcrw
Get alerted when CVE-2022-24822 or the next vulnerability affects your stack