What’s Vulnerable › Vulnerabilities
CVE-2022-24834: Heap overflow issue with the Lua cjson library used by Redis
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 41.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-13 · updated 2026-06-17
- Weakness: CWE-122
Description
Redis is an in-memory database that persists on disk. A specially crafted Lua script executing in Redis can trigger a heap overflow in the cjson library, and result with heap corruption and potentially remote code execution. The problem exists in all versions of Redis with Lua scripting support, starting from 2.6, and affects only authenticated and authorized users. The problem is fixed in versions 7.0.12, 6.2.13, and 6.0.20.
Affected products
- Fedoraproject Fedora: 37, 38
- Redis: from 2.6.0 before 6.0.20; from 6.2.0 before 6.2.13; from 7.0.0 before 7.0.12 — fixed in 6.0.20, 6.2.13, 7.0.12
How to fix
Upgrade to a fixed version: Redis 6.0.20, 6.2.13, 7.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/security/advisories/GHSA-p8x2-9v9q-c838
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MIF5MAGYARYUMRFK7PQI7HYXMK2HZE5T/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TDNNH2ONMVNBQ6LUIAOAGDNFPKXNST5K/
- https://security.netapp.com/advisory/ntap-20230814-0006/
- https://github.com/redis/redis/security/advisories/GHSA-p8x2-9v9q-c838
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MIF5MAGYARYUMRFK7PQI7HYXMK2HZE5T/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TDNNH2ONMVNBQ6LUIAOAGDNFPKXNST5K/
- https://security.netapp.com/advisory/ntap-20230814-0006/
Get alerted when CVE-2022-24834 or the next vulnerability affects your stack