What’s Vulnerable › Vulnerabilities
CVE-2022-24841: Improper Authorization in github.com/fleetdm/fleet
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-284
Description
fleetdm/fleet is an open source device management, built on osquery. All versions of fleet making use of the teams feature are affected by this authorization bypass issue. Fleet instances without teams, or with teams but without restricted team accounts are not affected. In affected versions a team admin can erroneously add themselves as admin, maintainer or observer on other teams. Users are advised to upgrade to version 4.13. There are no known workarounds for this issue.
Affected products
- fleetdm fleet: before 4.13 — fixed in 4.13
How to fix
Upgrade to a fixed version: fleetdm fleet 4.13. Check the vendor advisory for mitigations.
References
- https://github.com/fleetdm/fleet/commit/da171d3b8d149c30b8307723cbe6b6e8847cb30c
- https://github.com/fleetdm/fleet/security/advisories/GHSA-pr2g-j78h-84cr
- https://github.com/fleetdm/fleet/commit/da171d3b8d149c30b8307723cbe6b6e8847cb30c
- https://github.com/fleetdm/fleet/security/advisories/GHSA-pr2g-j78h-84cr
Get alerted when CVE-2022-24841 or the next vulnerability affects your stack