What’s Vulnerable › Vulnerabilities
CVE-2022-24844: SQL Injection in github.com/flipped-aurora/gin-vue-admin
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-13 · updated 2026-06-17
- Weakness: CWE-89
Description
Gin-vue-admin is a backstage management system based on vue and gin, which separates the front and rear of the full stack. The problem occurs in the following code in server/service/system/sys_auto_code_pgsql.go, which means that PostgreSQL must be used as the database for this vulnerability to occur. Users must: Require JWT login) and be using PostgreSQL to be affected. This issue has been resolved in version 2.5.1. There are no known workarounds.
Affected products
- flipped-aurora gin-vue-admin: before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: flipped-aurora gin-vue-admin 2.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/flipped-aurora/gin-vue-admin/pull/1024
- https://github.com/flipped-aurora/gin-vue-admin/security/advisories/GHSA-5g92-6hpp-w425
- https://github.com/flipped-aurora/gin-vue-admin/pull/1024
- https://github.com/flipped-aurora/gin-vue-admin/security/advisories/GHSA-5g92-6hpp-w425
Get alerted when CVE-2022-24844 or the next vulnerability affects your stack