What’s Vulnerable › Vulnerabilities
CVE-2022-24845: Integer bounds error in Vyper
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-13 · updated 2026-06-17
- Weakness: CWE-190
Description
Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In affected versions, the return of `<iface>.returns_int128()` is not validated to fall within the bounds of `int128`. This issue can result in a misinterpretation of the integer value and lead to incorrect behavior. As of v0.3.0, `<iface>.returns_int128()` is validated in simple expressions, but not complex expressions. Users are advised to upgrade. There is no known workaround for this issue.
Affected products
- vyperlang vyper: before 0.3.2 — fixed in 0.3.2
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b
- https://github.com/vyperlang/vyper/security/advisories/GHSA-j2x6-9323-fp7h
- https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b
- https://github.com/vyperlang/vyper/security/advisories/GHSA-j2x6-9323-fp7h
Get alerted when CVE-2022-24845 or the next vulnerability affects your stack