What’s Vulnerable › Vulnerabilities
CVE-2022-24850: Category group permissions leaked in Discourse
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-14 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open source platform for community discussion. A category's group permissions settings can be viewed by anyone that has access to the category. As a result, a normal user is able to see whether a group has read/write permissions in the category even though the information should only be available to the users that can manage a category. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. There are no workarounds for this problem.
Affected products
- discourse: before 2.8.2; 2.9.0-beta1, 2.9.0-beta2, 2.9.0-beta3 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: discourse 2.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-34xr-ff4w-mcpf
- https://github.com/discourse/discourse/security/advisories/GHSA-34xr-ff4w-mcpf
Get alerted when CVE-2022-24850 or the next vulnerability affects your stack