What’s Vulnerable › Vulnerabilities
CVE-2022-24856: Server-Side Request Forgery in FlyteConsole
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-17 · updated 2026-06-17
- Weakness: CWE-918
Description
FlyteConsole is the web user interface for the Flyte platform. FlyteConsole prior to version 0.52.0 is vulnerable to server-side request forgery (SSRF) when FlyteConsole is open to the general internet. An attacker can exploit any user of a vulnerable instance to access the internal metadata server or other unauthenticated URLs. Passing of headers to an unauthorized actor may occur. The patch for this issue deletes the entire `cors_proxy`, as this is not required for console anymore. A patch is available in FlyteConsole version 0.52.0. Disable FlyteConsole availability on the internet as a workaround.
Affected products
- flyteorg flyteconsole: before 0.52.0 — fixed in 0.52.0
How to fix
Upgrade to a fixed version: flyteorg flyteconsole 0.52.0. Check the vendor advisory for mitigations.
References
- https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709
- https://github.com/flyteorg/flyteconsole/pull/389
- https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0
- https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9
- https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709
- https://github.com/flyteorg/flyteconsole/pull/389
- https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0
- https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9
Get alerted when CVE-2022-24856 or the next vulnerability affects your stack