What’s Vulnerable › Vulnerabilities
CVE-2022-24858: Default redirect callback vulnerable to open redirects
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-19 · updated 2026-06-17
- Weakness: CWE-290
Description
next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.
Affected products
- nextauthjs next-auth: from 3.0.0 before 3.29.2; from 4.0.0 before 4.3.2 — fixed in 3.29.2, 4.3.2
How to fix
Upgrade to a fixed version: nextauthjs next-auth 3.29.2, 4.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-f9wg-5f46-cjmw
- https://next-auth.js.org/configuration/callbacks#redirect-callback
- https://next-auth.js.org/getting-started/upgrade-v4
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-f9wg-5f46-cjmw
- https://next-auth.js.org/configuration/callbacks#redirect-callback
- https://next-auth.js.org/getting-started/upgrade-v4
Get alerted when CVE-2022-24858 or the next vulnerability affects your stack