What’s Vulnerable › Vulnerabilities
CVE-2022-24863: Denial of service in http-swagger
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-400
Description
http-swagger is an open source wrapper to automatically generate RESTful API documentation with Swagger 2.0. In versions of http-swagger prior to 1.2.6 an attacker may perform a denial of service attack consisting of memory exhaustion on the host system. The cause of the memory exhaustion is down to improper handling of http methods. Users are advised to upgrade. Users unable to upgrade may to restrict the path prefix to the "GET" method as a workaround.
Affected products
- swaggo http-swagger: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: swaggo http-swagger 1.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/swaggo/http-swagger/commit/b7d83e8fba85a7a51aa7e45e8244b4173f15049e
- https://github.com/swaggo/http-swagger/pull/62
- https://github.com/swaggo/http-swagger/releases/tag/v1.2.6
- https://github.com/swaggo/http-swagger/security/advisories/GHSA-xg75-q3q5-cqmv
- https://github.com/swaggo/http-swagger/commit/b7d83e8fba85a7a51aa7e45e8244b4173f15049e
- https://github.com/swaggo/http-swagger/pull/62
- https://github.com/swaggo/http-swagger/releases/tag/v1.2.6
- https://github.com/swaggo/http-swagger/security/advisories/GHSA-xg75-q3q5-cqmv
Get alerted when CVE-2022-24863 or the next vulnerability affects your stack