What’s Vulnerable › Vulnerabilities
CVE-2022-24865: Improper access control in humhub
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-20 · updated 2026-06-17
- Weakness: CWE-200
Description
HumHub is an Open Source Enterprise Social Network. In affected versions users who are forced to change their password by an administrator may retrieve other users' data. This issue has been resolved by commit `eb83de20`. It is recommended that the HumHub is upgraded to 1.11.0, 1.10.4 or 1.9.4. There are no known workarounds for this issue.
Affected products
- humhub: before 1.9.4; from 1.10.0 before 1.10.4 — fixed in 1.10.4, 1.9.4
How to fix
Upgrade to a fixed version: humhub 1.10.4, 1.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/humhub/humhub/commit/eb83de20aaecc559ab77a44a6179646a99607e33
- https://github.com/humhub/humhub/security/advisories/GHSA-2h35-f226-3f57
- https://huntr.dev/bounties/89d996a2-de30-4261-8e3f-98e54cb25f76/
- https://github.com/humhub/humhub/commit/eb83de20aaecc559ab77a44a6179646a99607e33
- https://github.com/humhub/humhub/security/advisories/GHSA-2h35-f226-3f57
- https://huntr.dev/bounties/89d996a2-de30-4261-8e3f-98e54cb25f76/
Get alerted when CVE-2022-24865 or the next vulnerability affects your stack