What’s Vulnerable › Vulnerabilities
CVE-2022-24868: Cross site scripting via SVG file upload in GLPI
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. In versions prior to 10.0.0 one can exploit a lack of sanitization on SVG file uploads and inject javascript into their user avatar. As a result any user viewing the avatar will be subject to a cross site scripting attack. Users of GLPI are advised to upgrade. Users unable to upgrade should disallow SVG avatars.
Affected products
- glpi-project glpi: before 10.0.0 — fixed in 10.0.0
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/1aa9fcc4741a46fa5a9f11d71b409b911ffc190f
- https://github.com/glpi-project/glpi/security/advisories/GHSA-9hg4-fpwv-gx78
- https://github.com/glpi-project/glpi/commit/1aa9fcc4741a46fa5a9f11d71b409b911ffc190f
- https://github.com/glpi-project/glpi/security/advisories/GHSA-9hg4-fpwv-gx78
Get alerted when CVE-2022-24868 or the next vulnerability affects your stack