What’s Vulnerable › Vulnerabilities
CVE-2022-24871: Server-Side Request Forgery (SSRF) in Shopware
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-20 · updated 2026-06-17
- Weakness: CWE-918
Description
Shopware is an open commerce platform based on Symfony Framework and Vue. In affected versions an attacker can abuse the Admin SDK functionality on the server to read or update internal resources. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.
Affected products
- shopware: before 6.4.10.1 — fixed in 6.4.10.1
How to fix
Upgrade to a fixed version: shopware 6.4.10.1. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-04-2022
- https://github.com/shopware/platform/commit/083765e2d64a00315050c4891800c9e98ba0c77c
- https://github.com/shopware/platform/security/advisories/GHSA-7gm7-8q8v-9gf2
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-04-2022
- https://github.com/shopware/platform/commit/083765e2d64a00315050c4891800c9e98ba0c77c
- https://github.com/shopware/platform/security/advisories/GHSA-7gm7-8q8v-9gf2
Get alerted when CVE-2022-24871 or the next vulnerability affects your stack