What’s Vulnerable › Vulnerabilities
CVE-2022-24873: Non-Stored Cross-site Scripting in Shopware storefront
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.
Affected products
- shopware: from 5.0.0 before 5.7.9 — fixed in 5.7.9
How to fix
Upgrade to a fixed version: shopware 5.7.9. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
- https://github.com/shopware/shopware/security/advisories/GHSA-4g29-fccr-p59w
- https://www.shopware.com/en/changelog-sw5/#5-7-9
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
- https://github.com/shopware/shopware/security/advisories/GHSA-4g29-fccr-p59w
- https://www.shopware.com/en/changelog-sw5/#5-7-9
Get alerted when CVE-2022-24873 or the next vulnerability affects your stack