What’s Vulnerable › Vulnerabilities
CVE-2022-24878: Improper path handling in Kustomization files allows for denial of service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-06 · updated 2026-06-17
- Weakness: CWE-22
Description
Flux is an open and extensible continuous delivery solution for Kubernetes. Path Traversal in the kustomize-controller via a malicious `kustomization.yaml` allows an attacker to cause a Denial of Service at the controller level. Workarounds include automated tooling in the user's CI/CD pipeline to validate `kustomization.yaml` files conform with specific policies. This vulnerability is fixed in kustomize-controller v0.24.0 and included in flux2 v0.29.0. Users are recommended to upgrade.
Affected products
- fluxcd flux2: before 0.29.0 — fixed in 0.29.0
- fluxcd kustomize-controller: before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: fluxcd flux2 0.29.0; fluxcd kustomize-controller 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/fluxcd/flux2/security/advisories/GHSA-7pwf-jg34-hxwp
- https://github.com/fluxcd/flux2/security/advisories/GHSA-7pwf-jg34-hxwp
Get alerted when CVE-2022-24878 or the next vulnerability affects your stack