What’s Vulnerable › Vulnerabilities
CVE-2022-24879: Malfunction of Cross-Site Request Forgery token validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-28 · updated 2026-06-17
- Weakness: CWE-352
Description
Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.
Affected products
- shopware: from 5.2.0 before 5.7.9 — fixed in 5.7.9
How to fix
Upgrade to a fixed version: shopware 5.7.9. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
- https://github.com/shopware/shopware/security/advisories/GHSA-pf38-v6qj-j23h
- https://www.shopware.com/en/changelog-sw5/#5-7-9
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
- https://github.com/shopware/shopware/security/advisories/GHSA-pf38-v6qj-j23h
- https://www.shopware.com/en/changelog-sw5/#5-7-9
Get alerted when CVE-2022-24879 or the next vulnerability affects your stack