What’s Vulnerable › Vulnerabilities
CVE-2022-24889: Insufficient Verification of Data Authenticity in Nextcloud Server
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-27 · updated 2026-06-17
- Weakness: CWE-345
Description
Nextcloud Server is the file server software for Nextcloud, a self-hosted productivity platform. Prior to versions 21.0.8, 22.2.4, and 23.0.1, it is possible to trick administrators into enabling "recommended" apps for the Nextcloud server that they do not need, thus expanding their attack surface unnecessarily. This issue is fixed in versions 21.0.8 , 22.2.4, and 23.0.1.
Affected products
- Nextcloud Server: before 21.0.8; from 22.0.0 before 22.2.4; from 23.0.0 before 23.0.1 — fixed in 21.0.8, 22.2.4, 23.0.1
How to fix
Upgrade to a fixed version: Nextcloud Server 21.0.8, 22.2.4, 23.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6
- https://github.com/nextcloud/server/pull/30615
- https://hackerone.com/reports/1403614
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6
- https://github.com/nextcloud/server/pull/30615
- https://hackerone.com/reports/1403614
- https://security.gentoo.org/glsa/202208-17
Get alerted when CVE-2022-24889 or the next vulnerability affects your stack