What’s Vulnerable › Vulnerabilities
CVE-2022-24894: Symfony storing cookie headers in HttpCache
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-03 · updated 2026-06-17
- Weakness: CWE-285
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. The Symfony HTTP cache system, acts as a reverse proxy: It caches entire responses (including headers) and returns them to the clients. In a recent change in the `AbstractSessionListener`, the response might contain a `Set-Cookie` header. If the Symfony HTTP cache system is enabled, this response might bill stored and return to the next clients. An attacker can use this vulnerability to retrieve the victim's session. This issue has been patched and is available for branch 4.4.
Affected products
- symfony: from 2.0.0 before 4.4.50; from 5.0.0 before 5.4.2; from 6.0.0 before 6.0.20; from 6.1.0 before 6.1.12; from 6.2.0 before 6.2.6 — fixed in 4.4.50, 5.4.2, 6.0.20, 6.1.12, 6.2.6
- Packagist Symfony/Http-Kernel: from 2.0.0 before 4.4.50; from 5.0.0 before 5.4.20; from 6.0.0 before 6.0.20; from 6.1.0 before 6.1.12; from 6.2.0 before 6.2.6; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.12 (+611) — fixed in 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6
- Packagist Symfony/Symfony: from 2.0.0 before 4.4.50; from 5.0.0 before 5.4.20; from 6.0.0 before 6.0.20; from 6.1.0 before 6.1.12; from 6.2.0 before 6.2.6; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.11 (+625) — fixed in 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6
How to fix
Upgrade to a fixed version: symfony 4.4.50, 5.4.2, 6.0.20, 6.1.12; Packagist Symfony/Http-Kernel 4.4.50, 5.4.20, 6.0.20, 6.1.12; Packagist Symfony/Symfony 4.4.50, 5.4.20, 6.0.20, 6.1.12. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/d2f6322af9444ac5cd1ef3ac6f280dbef7f9d1fb
- https://github.com/symfony/symfony/security/advisories/GHSA-h7vf-5wrv-9fhv
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html
- https://github.com/symfony/symfony/commit/d2f6322af9444ac5cd1ef3ac6f280dbef7f9d1fb
- https://github.com/symfony/symfony/security/advisories/GHSA-h7vf-5wrv-9fhv
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html
Get alerted when CVE-2022-24894 or the next vulnerability affects your stack