What’s Vulnerable › Vulnerabilities
CVE-2022-24895: Symfony vulnerable to Session Fixation of CSRF tokens
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-03 · updated 2026-06-17
- Weakness: CWE-384
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. When authenticating users Symfony by default regenerates the session ID upon login, but preserves the rest of session attributes. Because this does not clear CSRF tokens upon login, this might enables same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. This issue has been fixed in the 4.4 branch.
Affected products
- symfony: from 2.0.0 before 4.4.50; from 5.0.0 before 5.4.20; from 6.0.0 before 6.0.20; from 6.1.0 before 6.1.12; from 6.2.0 before 6.2.6 — fixed in 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6
How to fix
Upgrade to a fixed version: symfony 4.4.50, 5.4.20, 6.0.20, 6.1.12. Check the vendor advisory for mitigations.
References
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-bundle/CVE-2022-24895.yaml
- https://github.com/symfony/security-bundle/commit/076fd2088ada33d760758d98ff07ddedbf567946
- https://github.com/symfony/symfony/commit/5909d74ecee359ea4982fcf4331aaf2e489a1fd4
- https://github.com/symfony/symfony/security/advisories/GHSA-3gv2-29qc-v67m
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-bundle/CVE-2022-24895.yaml
- https://github.com/symfony/security-bundle/commit/076fd2088ada33d760758d98ff07ddedbf567946
- https://github.com/symfony/symfony/commit/5909d74ecee359ea4982fcf4331aaf2e489a1fd4
- https://github.com/symfony/symfony/security/advisories/GHSA-3gv2-29qc-v67m
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html
Get alerted when CVE-2022-24895 or the next vulnerability affects your stack