What’s Vulnerable › Vulnerabilities
CVE-2022-24901: Authentication bypass and denial of service (DoS) vulnerabilities in Apple Game Center auth adapter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-04 · updated 2026-06-17
- Weakness: CWE-287
Description
Improper validation of the Apple certificate URL in the Apple Game Center authentication adapter allows attackers to bypass authentication, making the server vulnerable to DoS attacks. The vulnerability has been fixed by improving the URL validation and adding additional checks of the resource the URL points to before downloading it.
Affected products
- parse-community parse-server: before 4.10.10; from 5.0.0 before 5.2.1 — fixed in 4.10.10, 5.2.1
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.10, 5.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-qf8x-vqjv-92gr
- https://github.com/parse-community/parse-server/security/advisories/GHSA-qf8x-vqjv-92gr
Get alerted when CVE-2022-24901 or the next vulnerability affects your stack