What’s Vulnerable › Vulnerabilities
CVE-2022-24907
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-28 · updated 2026-06-17
- Weakness: CWE-125
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit PDF Reader 11.1.0.52543. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of JP2 images. Crafted data in a JP2 image can trigger a read past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-16186.
Affected products
- Foxit PDF Reader: before 10.1.7; from 11.0.0 before 11.2.1 — fixed in 10.1.7, 11.2.1
- Foxit Pdf Reader: before 11.2.1 — fixed in 11.2.1
How to fix
Upgrade to a fixed version: Foxit PDF Reader 10.1.7, 11.2.1; Foxit Pdf Reader 11.2.1. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-350/
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-350/
Get alerted when CVE-2022-24907 or the next vulnerability affects your stack