What’s Vulnerable › Vulnerabilities

CVE-2022-24921

Description

regexp.Compile in Go before 1.16.15 and 1.17.x before 1.17.8 allows stack exhaustion via a deeply nested expression.

Affected products

How to fix

Upgrade to a fixed version: Go 1.16.15, 1.17.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24921 or the next vulnerability affects your stack