What’s Vulnerable › Vulnerabilities
CVE-2022-24947: Apache JSPWiki CSRF Account Takeover
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-25 · updated 2026-06-17
- Weakness: CWE-352
Description
Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover. Apache JSPWiki users should upgrade to 2.11.2 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.11.2 — fixed in 2.11.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.11.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/02/25/1
- https://lists.apache.org/thread/txrgykjkpt80t57kzpbjo8kfrv8ss02c
- http://www.openwall.com/lists/oss-security/2022/02/25/1
- https://lists.apache.org/thread/txrgykjkpt80t57kzpbjo8kfrv8ss02c
Get alerted when CVE-2022-24947 or the next vulnerability affects your stack