What’s Vulnerable › Vulnerabilities
CVE-2022-24948: Apache JSPWiki Cross-site scripting vulnerability on User Preferences screen
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-25 · updated 2026-06-17
- Weakness: CWE-79
Description
A carefully crafted user preferences for submission could trigger an XSS vulnerability on Apache JSPWiki, related to the user preferences screen, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.2 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.11.2 — fixed in 2.11.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.11.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/02/25/2
- https://lists.apache.org/thread/86p0yzopc4mw2h5bkwpt927b2c8tfq3b
- http://www.openwall.com/lists/oss-security/2022/02/25/2
- https://lists.apache.org/thread/86p0yzopc4mw2h5bkwpt927b2c8tfq3b
Get alerted when CVE-2022-24948 or the next vulnerability affects your stack