What’s Vulnerable › Vulnerabilities
CVE-2022-24949
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-16 · updated 2026-06-17
- Weakness: CWE-362
Description
A privilege escalation to root exists in Eternal Terminal prior to version 6.2.0. This is due to the combination of a race condition, buffer overflow, and logic bug all in PipeSocketHandler::listen().
Affected products
- Jason Gauci Eternal Terminal: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: Jason Gauci Eternal Terminal 6.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/MisterTea/EternalTerminal/commit/900348bb8bc96e1c7ba4888ac8480f643c43d3c3
- https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-hxg8-4r3q-p9rv
- https://github.com/MisterTea/EternalTerminal/commit/900348bb8bc96e1c7ba4888ac8480f643c43d3c3
- https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-hxg8-4r3q-p9rv
Get alerted when CVE-2022-24949 or the next vulnerability affects your stack