What’s Vulnerable › Vulnerabilities
CVE-2022-24950
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-16 · updated 2026-06-17
- Weakness: CWE-362
Description
A race condition exists in Eternal Terminal prior to version 6.2.0 that allows an authenticated attacker to hijack other users' SSH authorization socket, enabling the attacker to login to other systems as the targeted users. The bug is in UserTerminalRouter::getInfoForId().
Affected products
- Jason Gauci Eternal Terminal: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: Jason Gauci Eternal Terminal 6.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/02/16/1
- https://github.com/MisterTea/EternalTerminal/commit/900348bb8bc96e1c7ba4888ac8480f643c43d3c3
- https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-85gw-pchc-4rf3
- http://www.openwall.com/lists/oss-security/2023/02/16/1
- https://github.com/MisterTea/EternalTerminal/commit/900348bb8bc96e1c7ba4888ac8480f643c43d3c3
- https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-85gw-pchc-4rf3
Get alerted when CVE-2022-24950 or the next vulnerability affects your stack