What’s Vulnerable › Vulnerabilities
CVE-2022-24952
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Several denial of service vulnerabilities exist in Eternal Terminal prior to version 6.2.0, including a DoS triggered remotely by an invalid sequence number and a local bug triggered by invalid input sent directly to the IPC socket.
Affected products
- Jason Gauci Eternal Terminal: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: Jason Gauci Eternal Terminal 6.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/02/16/1
- https://github.com/MisterTea/EternalTerminal/releases/tag/et-v6.2.0
- https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-8cw3-6r98-g7cw
- http://www.openwall.com/lists/oss-security/2023/02/16/1
- https://github.com/MisterTea/EternalTerminal/releases/tag/et-v6.2.0
- https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-8cw3-6r98-g7cw
Get alerted when CVE-2022-24952 or the next vulnerability affects your stack