What’s Vulnerable › Vulnerabilities
CVE-2022-24953
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-17 · updated 2026-06-17
- Weakness: CWE-88
Description
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
Affected products
- pear Crypt Gpg: before 1.6.7 — fixed in 1.6.7
How to fix
Upgrade to a fixed version: pear Crypt Gpg 1.6.7. Check the vendor advisory for mitigations.
References
- https://github.com/pear/Crypt_GPG/commit/29c0fbe96d0d4063ecd5c9a4644cb65a7fb7cc4e
- https://github.com/pear/Crypt_GPG/commit/74c8f989cefbe0887274b461dc56197e121bfd04
- https://github.com/pear/Crypt_GPG/commit/29c0fbe96d0d4063ecd5c9a4644cb65a7fb7cc4e
- https://github.com/pear/Crypt_GPG/commit/74c8f989cefbe0887274b461dc56197e121bfd04
Get alerted when CVE-2022-24953 or the next vulnerability affects your stack