What’s Vulnerable › Vulnerabilities

CVE-2022-24958

Description

drivers/usb/gadget/legacy/inode.c in the Linux kernel through 5.16.8 mishandles dev->buf release.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.270, 4.19.233, 4.9.305, 5.10.104. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24958 or the next vulnerability affects your stack