What’s Vulnerable › Vulnerabilities
CVE-2022-24959
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-401
Description
An issue was discovered in the Linux kernel before 5.16.5. There is a memory leak in yam_siocdevprivate in drivers/net/hamradio/yam.c.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Linux kernel: before 5.16.5 — fixed in 5.16.5
How to fix
Upgrade to a fixed version: Linux kernel 5.16.5. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.16.5
- https://github.com/torvalds/linux/commit/29eb31542787e1019208a2e1047bb7c76c069536
- https://lists.debian.org/debian-lts-announce/2022/03/msg00012.html
- https://www.debian.org/security/2022/dsa-5092
- https://www.debian.org/security/2022/dsa-5096
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.16.5
- https://github.com/torvalds/linux/commit/29eb31542787e1019208a2e1047bb7c76c069536
- https://lists.debian.org/debian-lts-announce/2022/03/msg00012.html
- https://www.debian.org/security/2022/dsa-5092
- https://www.debian.org/security/2022/dsa-5096
Get alerted when CVE-2022-24959 or the next vulnerability affects your stack