What’s Vulnerable › Vulnerabilities
CVE-2022-24976
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-287
Description
Atheme IRC Services before 7.2.12, when used in conjunction with InspIRCd, allows authentication bypass by ending an IRC handshake at a certain point during a challenge-response login sequence.
Affected products
- Atheme: from 7.2.0 before 7.2.12 — fixed in 7.2.12
How to fix
Upgrade to a fixed version: Atheme 7.2.12. Check the vendor advisory for mitigations.
References
- https://github.com/atheme/atheme/commit/4e664c75d0b280a052eb8b5e81aa41944e593c52
- https://github.com/atheme/atheme/compare/v7.2.11...v7.2.12
- https://www.openwall.com/lists/oss-security/2022/01/30/4
- https://github.com/atheme/atheme/commit/4e664c75d0b280a052eb8b5e81aa41944e593c52
- https://github.com/atheme/atheme/compare/v7.2.11...v7.2.12
- https://www.openwall.com/lists/oss-security/2022/01/30/4
Get alerted when CVE-2022-24976 or the next vulnerability affects your stack