What’s Vulnerable › Vulnerabilities
CVE-2022-24977
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-22
Description
ImpressCMS before 1.4.2 allows unauthenticated remote code execution via ...../// directory traversal in origName or imageName, leading to unsafe interaction with the CKEditor processImage.php script. The payload may be placed in PHP_SESSION_UPLOAD_PROGRESS when the PHP installation supports upload_progress.
Affected products
- ImpressCMS: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: ImpressCMS 1.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/ImpressCMS/impresscms/commit/a66d7bb499faafab803e24833606028fa0ba4261
- https://github.com/ImpressCMS/impresscms/compare/1.4.1...v1.4.2
- https://r0.haxors.org/posts?id=8
- https://github.com/ImpressCMS/impresscms/commit/a66d7bb499faafab803e24833606028fa0ba4261
- https://github.com/ImpressCMS/impresscms/compare/1.4.1...v1.4.2
- https://r0.haxors.org/posts?id=8
Get alerted when CVE-2022-24977 or the next vulnerability affects your stack