What’s Vulnerable › Vulnerabilities
CVE-2022-24988
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-193
Description
In galois_2p8 before 0.1.2, PrimitivePolynomialField::new has an off-by-one buffer overflow for a vector.
Affected products
- Galois 2P8 Project Galois 2P8: before 0.1.2 — fixed in 0.1.2
How to fix
Upgrade to a fixed version: Galois 2P8 Project Galois 2P8 0.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/djsweet/galois_2p8/blob/master/CHANGELOG.md
- https://github.com/djsweet/galois_2p8/blob/master/CHANGELOG.md
Get alerted when CVE-2022-24988 or the next vulnerability affects your stack