What’s Vulnerable › Vulnerabilities

CVE-2022-2500

Description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1. A stored XSS flaw in job error messages allows attackers to perform arbitrary actions on behalf of victims at client side.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.0.5, 15.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2500 or the next vulnerability affects your stack