What’s Vulnerable › Vulnerabilities

CVE-2022-2501

Description

An improper access control issue in GitLab EE affecting all versions from 12.0 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 allows an attacker to bypass IP allow-listing and download artifacts. This attack only bypasses IP allow-listing, proper permissions are still required.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.0.5, 15.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2501 or the next vulnerability affects your stack